Cisco Nexus VPc

VPc Anlegen

Als erstes müssen die entsprechenden Features aktiviert werden

N9K-1(config)# feature vpc
N9K-1(config)# feature lacp
auf beiden Nexus ausführen!

Danach werden den Management Interfaces IP Adressen zugewiesen

N9K-1:
N9K-1(config)# interface mgmt 0
N9K-1(config-if)# ip address 172.16.1.11/24
N9K-1(config-if)# no shutdown

N9K-2:
N9K-2(config)# interface mgmt 0
N9K-2(config-if)# ip address 172.16.1.12/24
N9K-2(config-if)# no shutdown

Die Erreichbarkeit prüfen :

N9K-1# ping 172.16.1.12 vrf management

Anlegen der VPC Domain.
In einer Domain können immer nur zwei verbundene Switche sein!
Über die “role priority” wird festgelegt welche der beiden Switche der Primary und welcher der Secondary ist.
Der Wert kann von 1 bis 65535 festgelegt werden. Wobei der Switch mit der niedrigsten Priority der Primary ist.

N9K-1:
N9K-1(config)# vpc domain 1
N9K-1(config-vpc-domain)# role priority 20
N9K-1(config-vpc-domain)# peer-keepalive destination 172.16.1.12 source 172.16.1.11 vrf management
N9K-1(config-vpc-domain)#

N9K-2:
N9K-2(config)# vpc domain 1
N9K-1(config-vpc-domain)# role priority 30
N9K-2(config-vpc-domain)# peer-keepalive destination 172.16.1.11 source 172.16.1.12 vrf management
N9K-2(config-vpc-domain)#

Den Peer Link anlegen
Über den Peer Link werden Status Informationen zwischen den Switchen ausgetauscht

N9K-1:
N9K-1(config)# interface ethernet 1/1-2
N9K-1(config-if-range)# channel-group 20 mode active
N9K-1(config-if-range)# no shutdown

N9K-1(config)# interface port-channel 20
N9K-1(config-if)# no shutdown
N9K-1(config-if)# switchport
N9K-1(config-if)# switchport mode trunk
N9K-1(config-if)# vpc peer-link
N9K-1(config-if)#spanning-tree port type network

N9K-2:
N9K-2(config)# interface ethernet 1/1-2
N9K-2(config-if-range)# channel-group 20 mode active
N9K-1(config-if-range)# no shutdown

N9K-2(config)# interface port-channel 20
N9K-2(config-if)# no shut
N9K-2(config-if)# switchport
N9K-2(config-if)# switchport mode trunk
N9K-2(config-if)# vpc peer-link
N9K-2(config-if)#spanning-tree port type network

Anlegen von Member Ports, das sin die Ports an denen die Devices angeschlossen werden

N9K-1:
N9K-1(config)# interface eth 1/3
N9K-1(config-if)# channel-group 30 mode active
!
N9K-1(config-if)# interface port-channel 30
N9K-1(config-if)# switchport
N9K-1(config-if)# vpc 30

N9K-2:
N9K-2(config)# interface eth 1/3
N9K-2(config-if)# channel-group 30 mode active
!
N9K-2(config-if)# interface port-channel 30
N9K-2(config-if)# switchport
N9K-2(config-if)# vpc 30

Die Kontrolle ob der VPC läuft erfolgt mit dem Befehl

N9K-1# show vpc brief  <– Übersicht über alle vPCs und deren Zustand sowie der zugeordneten VLANs
N9K-1# show vpc peer-keepalive <– Anzeige IP Adresse des Nachbarn und Zustand des Peer-Links
N9K-1# show vpc consistency-parameter <– Status der Parameter die für die konsitent vPC-Interfaces konfiguriert sein müssen
N9K-1#show running-config vpc <– vPC bezogene Konfiguration in der Running-Config anzeigen lassen
N9K-1#show vpc statistics <– Statistiken für den Peer-Link anzeigen
N9K-1#show vpr role <– Anzeige der Rolle des im vPC beteiligten Switches

 

N9K-1# show vpc consistency-parameter <– Status der Parameter die für die konsitent vPC-Interfaces konfiguriert sein müssen

Was muss alles gleich sein ?
– Portchannel Mode (on, off oder active)
– LinkSpeed pro PortChannel
– DuplexMode pro PortChannel
– Trunk mode pro PortChannel (native Vlan)
– Spanning Tree Protocol Mode
– Konfiguration der MSTP-Region
– Aktivierung oder Deaktivierung der VLANs
– globale Konfiguration des STP (Bridge Assurance, Port type und Loop Guard)
– STP-Konfiguration des Interfaces
– Quality-of-Service (Priority Flow Control, Queueing-Verfahren und MTU)

Paramater die gleich sein sollten
– Aging-time für MAC-Adressen
– statische MAC-Adress-Einträge
– alle Paramter und Konfiguratioonen der Access Control Liste
– STP-Interface-Einstellungen (BPDU-Filter, BPDU Guard, Cost, Link Type Priority, VLANs, (Rapid-PVST+)
– IGMP Snooping