DMVPN

Klassiche VPN Verbindungen oder GRE Tunnel erlaubten nur eine Punkt zu Punkt Verbindung, durch den Einsatz von DMVPN kann man auch Verbindungen 1 zu X herstellen ohne das für jeden Tunnel ein Destination Interface angelegt werden muss

Bei der Konfiguration kann man zwar die von jedem Spoke aus den nächsten Spoke erreichen, aber alles läuft über R1

Switch

switchname SW-1
!
interface Ethernet1/1
ip address 192.1.1.10/24
no shutdown
!
interface Ethernet1/2
ip address 192.1.2.10/24
no shutdown
!
interface Ethernet1/3
ip address 192.1.3.10/24
no shutdown
!
interface Ethernet1/4
ip address 192.1.4.10/24
no shutdown

R1

hostname R1
!
interface Tunnel1
ip address 10.1.1.1 255.255.255.0
no ip redirects
ip nhrp network-id 111
tunnel source 192.1.1.1
tunnel mode gre multipoint
!
interface Ethernet0/0
ip address 192.1.1.1 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 192.1.1.10

R2

hostname R2
!
interface Tunnel1
ip address 10.1.1.2 255.255.255.0
no ip redirects
ip nhrp map 10.1.1.1 192.1.1.1
ip nhrp network-id 222
ip nhrp nhs 10.1.1.1
tunnel source Ethernet0/0
tunnel mode gre multipoint
!
interface Ethernet0/0
ip address 192.1.2.1 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 192.1.2.10

R3

hostname R3
!
interface Tunnel1
ip address 10.1.1.3 255.255.255.0
no ip redirects
ip nhrp map 10.1.1.1 192.1.1.1
ip nhrp network-id 333
ip nhrp nhs 10.1.1.1
tunnel source Ethernet0/0
tunnel mode gre multipoint
!
interface Ethernet0/0
ip address 192.1.3.1 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 192.1.3.10

R4

hostname R4
!
interface Tunnel1
ip address 10.1.1.4 255.255.255.0
no ip redirects
ip nhrp map 10.1.1.1 192.1.1.1
ip nhrp network-id 444
ip nhrp nhs 10.1.1.1
tunnel source Ethernet0/0
tunnel mode gre multipoint
!
interface Ethernet0/0
ip address 192.1.4.1 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 192.1.4.10