EVPN VXLAN mit Nexus

Erstellen eines VXLANs mit EVPN auf Cisco Nexus Basis.
Läuft nicht richtig, da das Routing angepasst werden muss.

Grundlage https://www.zccie.com/network/dc/684/

Used images for lab:
nxosv9k-7.0.3.I7.1, x4CPU, 8Gb RAM each
IOL L3 15.4.2T Routers
vIOS L2 15.2 Switches
VPCS VMs

WAN-R1
interface Loopback100
ip address 8.8.8.8 255.255.255.255
!
interface gig0/0
ip address 40.1.1.2 255.255.255.0

router bgp 200
bgp log-neighbor-changes
neighbor 40.1.1.1 remote-as 100
!
address-family ipv4
network 8.8.8.8 mask 255.255.255.255
network 100.0.0.0 mask 255.255.255.0
network 100.0.1.0 mask 255.255.255.0
neighbor 40.1.1.1 activate
exit-address-family

ip route 100.0.0.0 255.255.255.0 Null0
ip route 100.0.1.0 255.255.255.0 Null0


VTEP-1# show running-config

nv overlay evpn
feature ospf
feature bgp
feature pim
feature interface-vlan
feature vn-segment-vlan-based
feature nv overlay

ip pim rp-address 100.100.100.3 group-list 224.0.0.0/4
ip pim ssm range 232.0.0.0/8
vlan 1,200,210
vlan 200
vn-segment 20000
vlan 210
vn-segment 20010

interface nve1
no shutdown
host-reachability protocol bgp
source-interface loopback0
member vni 20000
mcast-group 230.1.1.1
member vni 20010
mcast-group 230.1.1.2

interface Ethernet1/1
switchport mode trunk
switchport trunk allowed vlan 200,210

interface Ethernet1/2
no switchport
ip address 20.1.1.2/24
ip router ospf 1 area 0.0.0.0
ip pim sparse-mode
no shutdown

interface loopback0
ip address 100.100.100.1/32
ip router ospf 1 area 0.0.0.0
ip pim sparse-mode

router ospf 1
router-id 100.100.100.1

router bgp 100
router-id 100.100.100.1
log-neighbor-changes
address-family ipv4 unicast
address-family l2vpn evpn
neighbor 100.100.100.3
remote-as 100
update-source loopback0
address-family ipv4 unicast
address-family l2vpn evpn
send-community extended
evpn
vni 20000 l2
rd auto
route-target import auto
route-target export auto
vni 20010 l2
rd auto
route-target import auto
route-target export auto

cli alias name save copy run start


VTEP-2# show running-config

nv overlay evpn
feature ospf
feature bgp
feature pim
feature interface-vlan
feature vn-segment-vlan-based
feature nv overlay

ip pim rp-address 100.100.100.3 group-list 224.0.0.0/4
ip pim ssm range 232.0.0.0/8
vlan 1,200,210
vlan 200
vn-segment 20000
vlan 210
vn-segment 20010

interface nve1
no shutdown
host-reachability protocol bgp
source-interface loopback0
member vni 20000
mcast-group 230.1.1.1
member vni 20010
mcast-group 230.1.1.2

interface Ethernet1/1
switchport mode trunk
switchport trunk allowed vlan 200,210

interface Ethernet1/2
no switchport
ip address 30.1.1.2/24
ip router ospf 1 area 0.0.0.0
ip pim sparse-mode
no shutdown

interface loopback0
ip address 100.100.100.2/32
ip router ospf 1 area 0.0.0.0
ip pim sparse-mode

router ospf 1
router-id 100.100.100.2
router bgp 100
router-id 100.100.100.2
log-neighbor-changes
address-family ipv4 unicast
address-family l2vpn evpn
neighbor 100.100.100.3
remote-as 100
update-source loopback0
address-family ipv4 unicast
address-family l2vpn evpn
send-community extended
evpn
vni 20000 l2
rd auto
route-target import auto
route-target export auto
vni 20010 l2
rd auto
route-target import auto
route-target export auto

cli alias name save copy run start

RR# show running-config

nv overlay evpn
feature ospf
feature bgp
feature pim
feature interface-vlan
feature vn-segment-vlan-based
feature nv overlay

ip pim rp-address 100.100.100.3 group-list 224.0.0.0/4
ip pim ssm range 232.0.0.0/8

interface Ethernet1/1
no switchport
ip address 20.1.1.1/24
ip router ospf 1 area 0.0.0.0
ip pim sparse-mode
no shutdown

interface Ethernet1/2
no switchport
ip address 30.1.1.1/24
ip router ospf 1 area 0.0.0.0
ip pim sparse-mode
no shutdown

interface loopback0
ip address 100.100.100.3/32
ip router ospf 1 area 0.0.0.0
ip pim sparse-mode

router ospf 1
router-id 100.100.100.3
router bgp 100
router-id 100.100.100.3
log-neighbor-changes
address-family ipv4 unicast
address-family l2vpn evpn
neighbor 100.100.100.1
remote-as 100
update-source loopback0
address-family ipv4 unicast
address-family l2vpn evpn
send-community extended
route-reflector-client
neighbor 100.100.100.2
remote-as 100
update-source loopback0
address-family ipv4 unicast
address-family l2vpn evpn
send-community extended
route-reflector-client

cli alias name save copy run start

Switch1#show running-config

interface Ethernet0/0
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Ethernet0/1
switchport access vlan 200
!
interface Ethernet0/2
switchport access vlan 210
!

Switch2#show running-config

interface Ethernet0/0
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Ethernet0/1
switchport access vlan 200
!
interface Ethernet0/2
switchport access vlan 210
!

Überprüfen

RR# show bgp l2vpn evpn summary
BGP summary information for VRF default, address family L2VPN EVPN
BGP router identifier 100.100.100.3, local AS number 100
BGP table version is 4, L2VPN EVPN config peers 2, capable peers 2
0 network entries and 0 paths using 0 bytes of memory
BGP attribute entries [0/0], BGP AS path entries [0/0]
BGP community entries [0/0], BGP clusterlist entries [0/0]

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
100.100.100.1 4 100 14 14 4 0 0 00:05:53 0
100.100.100.2 4 100 12 12 4 0 0 00:03:28 0

VTEP1# sh bgp l2vpn evpn summary
BGP summary information for VRF default, address family L2VPN EVPN
BGP router identifier 100.100.100.1, local AS number 100
BGP table version is 3, L2VPN EVPN config peers 1, capable peers 1
0 network entries and 0 paths using 0 bytes of memory
BGP attribute entries [0/0], BGP AS path entries [0/0]
BGP community entries [0/0], BGP clusterlist entries [0/0]

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
100.100.100.3 4 100 13 13 3 0 0 00:04:34 0


VTEP2# sh bgp l2vpn evpn summary

BGP summary information for VRF default, address family L2VPN EVPN
BGP router identifier 100.100.100.2, local AS number 100
BGP table version is 3, L2VPN EVPN config peers 1, capable peers 1
0 network entries and 0 paths using 0 bytes of memory
BGP attribute entries [0/0], BGP AS path entries [0/0]
BGP community entries [0/0], BGP clusterlist entries [0/0]

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
100.100.100.3 4 100 11 11 3 0 0 00:02:59 0