IOS XR – EIGRP

EIGRP auf Cisco IOS XR Systemen

Das Netzwerk

Die Konfiguration der Interface können aus dem Bild abgeleitet werden

IOS XR

interface Loopback1
ipv4 address 1.1.1.1 255.255.255.255
!
interface Loopback11
ipv4 address 11.11.11.11 255.255.255.255
!
interface MgmtEth0/0/CPU0/0
shutdown
!
interface GigabitEthernet0/0/0/0
ipv4 address 10.10.10.1 255.255.255.252
!
interface GigabitEthernet0/0/0/1
ipv4 address 20.20.20.1 255.255.255.252
!
interface GigabitEthernet0/0/0/2
ipv4 address 30.30.30.1 255.255.255.252
!

IOS

interface Loopback2
ip address 2.2.2.2 255.255.255.255
!
interface Loopback22
ip address 22.22.22.22 255.255.255.255
!
interface GigabitEthernet0/0
ip address 10.10.10.2 255.255.255.252
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/1
ip address 20.20.20.2 255.255.255.252
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/2
ip address 30.30.30.2 255.255.255.252
duplex auto
speed auto
media-type rj45
!

Die Konfiguration für EIGRP

IOS XR

router eigrp 100
address-family ipv4
router-id 1.1.1.1
interface Loopback1
!
interface GigabitEthernet0/0/0/0
!
interface GigabitEthernet0/0/0/1
!
!

!

IOS

router eigrp 100
network 2.0.0.0
network 10.10.10.0 0.0.0.3
network 20.20.20.0 0.0.0.3
eigrp router-id 2.2.2.2
!

Das ganze überprüfen

IOS XR

RP/0/0/CPU0:IOS-XR#sh eigrp topology

IPv4-EIGRP Topology Table for AS(100)/ID(1.1.1.1)

Codes: P – Passive, A – Active, U – Update, Q – Query, R – Reply,
r – reply Status, s – sia Status

P 1.1.1.1/32, 1 successors, FD is 131072, RIB is 1024
via Connected, Loopback1
P 2.2.2.2/32, 2 successors, FD is 328990720, RIB is 2570240
via 10.10.10.2 (328990720/327761920), GigabitEthernet0/0/0/0
via 20.20.20.2 (328990720/327761920), GigabitEthernet0/0/0/1
P 10.10.10.0/30, 1 successors, FD is 1310720, RIB is 10240
via Connected, GigabitEthernet0/0/0/0
P 20.20.20.0/30, 1 successors, FD is 1310720, RIB is 10240
via Connected, GigabitEthernet0/0/0/1

RP/0/0/CPU0:IOS-XR#sh route eigrp

D 2.2.2.2/32 [90/2570240] via 20.20.20.2, 00:01:52, GigabitEthernet0/0/0/1
[90/2570240] via 10.10.10.2, 00:01:52, GigabitEthernet0/0/0/0

RP/0/0/CPU0:IOS-XR#sh eigrp neighbors

IPv4-EIGRP Neighbors for AS(100) VRF default

H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
1 20.20.20.2 Gi0/0/0/1 14 00:04:56 1 200 0 14
0 10.10.10.2 Gi0/0/0/0 14 00:04:56 1 200 0 15

IOS

IOS#sh ip eigrp topology
EIGRP-IPv4 Topology Table for AS(100)/ID(2.2.2.2)
Codes: P – Passive, A – Active, U – Update, Q – Query, R – Reply,
r – reply Status, s – sia Status

P 20.20.20.0/30, 1 successors, FD is 2816
via Connected, GigabitEthernet0/1
P 2.2.2.2/32, 1 successors, FD is 128256
via Connected, Loopback2
P 10.10.10.0/30, 1 successors, FD is 2816
via Connected, GigabitEthernet0/0
P 1.1.1.1/32, 2 successors, FD is 2841
via 10.10.10.1 (2841/281), GigabitEthernet0/0
via 20.20.20.1 (2841/281), GigabitEthernet0/1

IOS#sh ip route eigrp
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route, H – NHRP, l – LISP
a – application route
+ – replicated route, % – next hop override, p – overrides from PfR

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets
D 1.1.1.1 [90/2841] via 20.20.20.1, 00:02:38, GigabitEthernet0/1
[90/2841] via 10.10.10.1, 00:02:38, GigabitEthernet0/0

IOS#sh ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(100)
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
1 20.20.20.1 Gi0/1 13 00:04:00 32 192 0 9
0 10.10.10.1 Gi0/0 13 00:04:00 28 168 0 10

Die Grundkonfiguration wurde nun hergestellt und die Systeme sehen sich und lernen die Netze von der Gegenseite

Ab und zu kann es sein das die Hello und Hold Timer angepasst werden müssen.
Standart sind 5 sekunden für hello und 15 Sekunden für den Hold Timer.

Wie ändert man diese nun ?

IOS XR

für das Interface Gi0/0/0/0

router eigrp 100
address-family ipv4
router-id 1.1.1.1
interface Loopback1
!
interface GigabitEthernet0/0/0/0
hello-interval 8
hold-time 24

!

Kontrolle

RP/0/0/CPU0:IOS-XR#sh eigrp interfaces detail
Tue Apr 9 12:25:09.234 UTC

IPv4-EIGRP Interfaces for AS(100)

Xmit Queue Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes
Gi0/0/0/0 1 0/0 50 0/10 252 0
Hello interval is 8 sec, hold time is 24 sec

BFD disabled, BFD interval 150 msec, BFD multiplier is 3
Next xmit serial
Un/reliable mcasts: 0/2 Un/reliable ucasts: 6/7
Mcast exceptions: 0 CR packets: 0 ACKs suppressed: 1
Retransmissions sent: 1 Out-of-sequence rcvd: 0
Bandwidth percent is 50
Total packets received: 191
Authentication mode is not set
Classic peers : 0, Wide peers: 1
Effective Metric:
Bandwidth: 1000000 Kbit, Delay: 10000000 picosecond,
Reliability: 255, Load: 1, MTU: 1500

Gi0/0/0/1 1 0/0 1 0/10 50 0
Hello interval is 5 sec, hold time is 15 sec

BFD disabled, BFD interval 150 msec, BFD multiplier is 3
Next xmit serial
Un/reliable mcasts: 0/3 Un/reliable ucasts: 7/7
Mcast exceptions: 0 CR packets: 0 ACKs suppressed: 1
Retransmissions sent: 1 Out-of-sequence rcvd: 0
Bandwidth percent is 50
Total packets received: 228
Authentication mode is not set
Classic peers : 0, Wide peers: 1
Effective Metric:
Bandwidth: 1000000 Kbit, Delay: 10000000 picosecond,
Reliability: 255, Load: 1, MTU: 1500

IOS

hier werden nur die Timer auf dem Interface gi0/0 geändert

interface GigabitEthernet0/0
ip address 10.10.10.2 255.255.255.252
ip hello-interval eigrp 100 10
ip hold-time eigrp 100 30

duplex auto
speed auto
media-type rj45
!

Kontrolle

IOS#sh ip eigrp interfaces detail
EIGRP-IPv4 Interfaces for AS(100)
Xmit Queue PeerQ Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable Un/Reliable SRTT Un/Reliable Flow Timer Routes
Gi0/0 1 0/0 0/0 26 0/0 116 0
Hello-interval is 10, Hold-time is 30

Split-horizon is enabled
Next xmit serial
Packetized sent/expedited: 10/1
Hello’s sent/expedited: 220/10
Un/reliable mcasts: 0/8 Un/reliable ucasts: 7/7
Mcast exceptions: 0 CR packets: 0 ACKs suppressed: 0
Retransmissions sent: 4 Out-of-sequence rcvd: 0
Topology-ids on interface – 0
Authentication mode is not set
Topologies advertised on this interface: base
Topologies not advertised on this interface:

Gi0/1 1 0/0 0/0 21 0/0 92 0
Hello-interval is 5, Hold-time is 15

Split-horizon is enabled
Next xmit serial
Packetized sent/expedited: 10/0
Hello’s sent/expedited: 265/9
Un/reliable mcasts: 0/10 Un/reliable ucasts: 9/3
Mcast exceptions: 0 CR packets: 0 ACKs suppressed: 0
Retransmissions sent: 1 Out-of-sequence rcvd: 0
Topology-ids on interface – 0
Authentication mode is not set
Topologies advertised on this interface: base
Topologies not advertised on this interface:

Diese Timer sind nicht gleich konfiguriert aber EIGRP formt trotzdem die Nachbarschaft.
Sinn macht das ganze aber nicht

Passiv Interface

Manche Interfaces sollen zwar im EIGRP Routing eingebunden sein, aber sollen keine Verbindung mit dem Nachbarn eingehen.
Dafür gibt es die Funktion Passiv Interface

Entweder kann man ein einzelnes Interface passiv setzen, oder man kann alle als passiv konfigurieren und nur einzelne ausnehmen. Welche Variante man nimmt, hängt immer von der Situation ab.

IOS XR

Das Interface gig 0/0/0/1 als passiv setzen

router eigrp 100
address-family ipv4
interface GigabitEthernet0/0/0/1
passive-interface
!

IOS

router eigrp 100
passive-interface GigabitEthernet0/1
!

Alle Interfaces als passiv setzen und ausnahmen setzen

IOS XR


router eigrp 100
address-family ipv4
passive-interface default
interface Loopback1
!
interface GigabitEthernet0/0/0/0
passive-interface disable
hello-interval 8
hold-time 24
!
interface GigabitEthernet0/0/0/1
!

IOS

router eigrp 100
network 2.0.0.0
network 10.10.10.0 0.0.0.3
network 20.20.20.0 0.0.0.3
passive-interface default
no passive-interface GigabitEthernet0/0
eigrp router-id 2.2.2.2
!