Cisco Nexus Port Profile

Damit man die immer gleiche Konfig nicht auf jedem Port eintragen muss oder auch Änderungen schnelle auf vielen Ports gemacht werden können, kann man bei den Cisco Nexus mit Port Profilen arbeiten.

Was muss dazu getan werden ?

Portprofil anlegen
Portprofil konfigurieren
Portprofil den Ports zuweisen.

Profil anlegen

Der Befehl dazu:
port-profile type [ethernet | interface-vlan | port-channel] [name]

Beispiel:
N9K-1(config)# port-profile type ethernet MeinPortProfilName

Anlegen des Profils

N9K-1(config)# port-profile type ethernet MeinPortProfilName
N9K-1(config-port-prof)# no shutdown
N9K-1(config-port-prof)# switchport mode access
N9K-1(config-port-prof)# switchport access vlan 10
N9K-1(config-port-prof)# spanning-tree port type edge

N9K-1# show port-profile

SHOW PORT_PROFILE

port-profile MeinPortProfilName
type: Ethernet
description:
status: disabled <– noch nicht aktiviert
max-ports: 16384
inherit:
config attributes:
spanning-tree port type edge
switchport
switchport access vlan 10
no shutdown
evaluated config attributes:
spanning-tree port type edge
switchport
switchport access vlan 10
no shutdown
assigned interfaces:

Portprofil aktivieren

N9K-1(config)# port-profile type ethernet MeinPortProfilName
N9K-1(config-port-prof)# state enabled

N7K-01# show port-profile

SHOW PORT_PROFILE

port-profile MeinPortProfilName
type: Ethernet
description:
status: enabled <– aktiviert
max-ports: 16384
inherit:
config attributes:
spanning-tree port type edge
switchport
switchport access vlan 10
no shutdown
evaluated config attributes:
spanning-tree port type edge
switchport
switchport access vlan 10
no shutdown
assigned interfaces:

Das Portprofil einem Interface zuweisen

Befehl:
inherit port-profile [name]

Beispiel:
N9K-1(config)# interface e1/1-5
N9K-1(config-if-range)# inherit port-profile MeinPortProfilName

Zum Überprüfen des ganzen gibt es die folgenden Befehle

show port-profile
show run interface [interface range]
show port-profile expand-interface name [name]