vWLC 9800 – Grundinstallation

Grundkonfiguration eine virtuellen WLAN Controllers von Cisco
In diesem Fall geht es um den 9800-CL auf einem ESXi

Bei Cisco wird das OVA File runter geladen und dann kann man es auf dem ESXi Server installieren.

Der vWLC hat drei Interfaces und diese müssen auch beschaltet werden.
Bei mir habe ich folgende Netze zur Verfügung

VLAN 172 – 192.168.172.0/24
wird genutzt als ServicePort beim “alten” vWLC und die AccessPoints sind auch in das VLAN geschaltet

VLAN 174 – 192.168.174.0/24
In diesem VLAN befinden sich meine Clients

VLAN 500 – 192.168.176.0/24
Hier drin befinden sich meine Server und es wird als Management VLAN genommen

Beim 9800-CL habe ich die Interfaces folgendermassen beschaltet

Int Gig 1 – Trunk
Int Gig 2 – VLAN 500
Int Gig 3 – VLAN 172

Nachdem das Image installiert wurde und der WLC hochgelaufen ist, kommt die Anzeige ob wir den configuration dialog starten wollen, dieses verneinen!
Auch das Autoinstall deaktivieren!

jetzt können wir auf der Conscole los legen und den WLC konfigurieren.

Hostname
!
conf t
hostname vwlc-9800
!

Vlans einrichten, Layer2 und Layer 3
!
conf t
!
int vlan 1
no ip add
shut
!
int vlan 172
desc ServicePort-AP-Netz
ip add 192.168.172.17 255.255.255.0
no shut
!
int vlan 174
desc Client
ip add 192.168.174.17 255.255.255.0
no shut
!
int vlan 500
desc Management
ip add 192.168.176.17 255.255.255.0
no shut
!

vlan 172
name Service-AP
!
vlan 174
name Client
!
vlan 500
name Management
!

Die VLANs den netzwerkkarten zuweisen

!
int gig 1
switchport
switchport mode trunk
exit
!
int gig 2
switchport
sw access vlan 500
no shut
exit
!
int gig 3
switchport
sw acc vlan 172
no shut
exit
!

Die default Route festlegen, ich schicke alles über den Stadart Gateway 192.168.176.20 (mein Layer 3 Interface auf dem Switch)
!
ip route 0.0.0.0 0.0.0.0 192.168.176.20
!

User anlegen
!
username admin priv 15 password 0 Cisco123
!

Das einloggen auf der “seriellen” Schnittstelle erlauben und festlegen wie die Authentifizierung statt finden soll
local authentication für VTY

!
line vty 0 15
login local
!

Management Interface festlegen
!
wirless management interface vlan 500
wireless mgmt-via-wireless
!

Radios 2,4GHz und 5 GHz deaktivieren zum einstellen des Ländercodes
!
conf t
ap dot11 24ghz shut
ap dot11 5ghz shut
!

Ländercode festlegen
!
ap country DE <-- in Grossbuchstaben!!
!

enable Radios
!
conf t
ap dot11 24ghz no shut
ap dot11 5ghz no shut
!

Domain Auflösung
!
conf t
ip name-server 1.1.1.1 oder lokalen DNS Server
!

Zeitserver festlegen
!
ntp Server
!
conf t
ntp server 192.168.170.1
!

self sign Zertifkat erstellen
!
wireless config vwlc-ssc key-size 2048 signature-algo sha256 password 0 !

prüfen
!
show wireless management trustpoint
!

Jetzt können wir uns auf der Weboberfläche anmelden.